Nouveau plug-in, travail en cours...

    Partagez

    kx77free
    Réponse à tout

    Nombre de messages : 794
    Date d'inscription : 04/09/2005

    Nouveau plug-in, travail en cours...

    Message  kx77free le Mer 23 Mai 2012 - 14:59

    Salut,


    Je travaille sur un nouveau plug-in, basé sur une architecture similaire au KXPM23.
    C'est à dire la structure classique d'un mini : 3 vcos + SFO > mixer > vcf > vca.

    Le challenge pour ce plug est de faire un skin à un seul panneau, d'éviter une installation en copiant des fichiers complémentaires (waveforms,sem etc...)et que la conso cpu soit raisonnable, largement inférieure à celle de mes modulaires.

    J'ai fini le skin et j'ai pu y mettre :
    une matrice (6*15*12),4 kxmod, 1 lfo, 3 vcos, 1 Sfo, 1 ring modulator, 4 enveloppes, 1 dual vcf, 1 vca, 1 disto, 2 fx...

    La conso cpu est en moyenne à 10% pour 6 notes contre 16% pour le Kx-synth-x16( premier preset).

    La question que je voulais vous poser est par rapport aux fichiers zippés dans la Dll:

    Est-ce que vous avez eu avec les dlls vst faites avec SE (1.1) des problèmes de décompression des fichiers SEM (ou autre) suivant votre configuration (Seven, Vista, Xp)?

    En fait le moteur SE du vst, à la première initialisation du plug-in, copie les modules sem dans un dossier du même nom.

    Avec Vista et Seven parfois cela ne fonctionne pas si vous n'avez pas tous les droits sur le dossier Vstplugins qui est souvent installé dans le dossier program file (donc protégé)

    Pour résoudre ce problème souvent je fourni mes modules sem dans le zip (kx-synth-x16 et kx-modulad) mais pour ce plug-in je voudrais éviter de le faire. Comme cela l'utilisateur aura juste à copier la dll pour l'installation.

    a+
















    Solstice
    Retenez moi ou je poste encore !

    Nombre de messages : 1497
    Age : 39
    Date d'inscription : 05/03/2007

    Re: Nouveau plug-in, travail en cours...

    Message  Solstice le Mer 23 Mai 2012 - 18:28

    kx77free a écrit:Salut,


    Je travaille sur un nouveau plug-in, basé sur une architecture similaire au KXPM23.
    C'est à dire la structure classique d'un mini : 3 vcos + SFO > mixer > vcf > vca.

    Le challenge pour ce plug est de faire un skin à un seul panneau, d'éviter une installation en copiant des fichiers complémentaires (waveforms,sem etc...)et que la conso cpu soit raisonnable, largement inférieure à celle de mes modulaires.

    J'ai fini le skin et j'ai pu y mettre :
    une matrice (6*15*12),4 kxmod, 1 lfo, 3 vcos, 1 Sfo, 1 ring modulator, 4 enveloppes, 1 dual vcf, 1 vca, 1 disto, 2 fx...

    La conso cpu est en moyenne à 10% pour 6 notes contre 16% pour le Kx-synth-x16( premier preset).

    La question que je voulais vous poser est par rapport aux fichiers zippés dans la Dll:

    Est-ce que vous avez eu avec les dlls vst faites avec SE (1.1) des problèmes de décompression des fichiers SEM (ou autre) suivant votre configuration (Seven, Vista, Xp)?

    En fait le moteur SE du vst, à la première initialisation du plug-in, copie les modules sem dans un dossier du même nom.

    Avec Vista et Seven parfois cela ne fonctionne pas si vous n'avez pas tous les droits sur le dossier Vstplugins qui est souvent installé dans le dossier program file (donc protégé)

    Pour résoudre ce problème souvent je fourni mes modules sem dans le zip (kx-synth-x16 et kx-modulad) mais pour ce plug-in je voudrais éviter de le faire. Comme cela l'utilisateur aura juste à copier la dll pour l'installation.

    a+
    Pas de problème répertorié de mon côté.

    zeetoon
    Réponse à tout

    Nombre de messages : 791
    Age : 56
    Localisation : Les pieds à Périgueux la tête à Paimpol
    Date d'inscription : 04/06/2005

    Re: Nouveau plug-in, travail en cours...

    Message  zeetoon le Sam 16 Juin 2012 - 18:57

    Jamais sous XP, ni sous 7.

    novaflash
    L'incontournable

    Nombre de messages : 418
    Age : 105
    Localisation : Mars, Solar System
    Date d'inscription : 20/06/2005

    Re: Nouveau plug-in, travail en cours...

    Message  novaflash le Mar 19 Juin 2012 - 9:16

    j'ai eu des rapports de problèmes sous ableton live! + win7 à ce sujet.
    Depuis je met les modules pré-extraits dans l'archive.





    _________________
    http://www.novaflash.com/

    kx77free
    Réponse à tout

    Nombre de messages : 794
    Date d'inscription : 04/09/2005

    Re: Nouveau plug-in, travail en cours...

    Message  kx77free le Mar 19 Juin 2012 - 14:34

    Re,

    Je n'avais pas vu ta réponse.

    Est-ce que tu as eu des problèmes liés au fait que tu compresses la dll?

    Cela m'embête, j'aurais bien voulu ne pas être obligé de fournir les SEMs avec la DLL, histoire de simplifier l'installation.

    C'est la même raison pour laquelle je fournis les SEMs dans mes zips, Deb76 avait eu ce problème avec Live sous Vista en 2008. Mais depuis je n'ai pas vérifié si ce bug était encore présent sur certaines configs.

    a+

    novaflash
    L'incontournable

    Nombre de messages : 418
    Age : 105
    Localisation : Mars, Solar System
    Date d'inscription : 20/06/2005

    Re: Nouveau plug-in, travail en cours...

    Message  novaflash le Mar 19 Juin 2012 - 15:00

    "Est-ce que tu as eu des problèmes liés au fait que tu compresses la dll?"
    jamais aucun problème signalé avec UPX


    _________________
    http://www.novaflash.com/

    kx77free
    Réponse à tout

    Nombre de messages : 794
    Date d'inscription : 04/09/2005

    Re: Nouveau plug-in, travail en cours...

    Message  kx77free le Mar 19 Juin 2012 - 18:02

    re,

    Est-ce que le fait de compresser la dll peut créer ce bug?

    Sinon je peux faire 2 zips, l'un avec les SEM et l'autre qu'avec la dll.

    a+



    Dernière édition par kx77free le Mar 19 Juin 2012 - 18:43, édité 1 fois

    novaflash
    L'incontournable

    Nombre de messages : 418
    Age : 105
    Localisation : Mars, Solar System
    Date d'inscription : 20/06/2005

    Re: Nouveau plug-in, travail en cours...

    Message  novaflash le Mar 19 Juin 2012 - 18:14

    non je ne pense pas, j'avais fait des tests sans UPX
    avec l'utilisateur en question et ça ne changeait rien.
    en fin de compte c'était le classique problème de droits par
    défaut du répertoire.


    _________________
    http://www.novaflash.com/

    kx77free
    Réponse à tout

    Nombre de messages : 794
    Date d'inscription : 04/09/2005

    Re: Nouveau plug-in, travail en cours...

    Message  kx77free le Mar 19 Juin 2012 - 18:32

    Re,

    Ouais et si on informe les utilisateurs de ce bug en amont par une FAQ, la plupart ne l'auront pas lue. C'est très embêtant.


    Jusqu'où doit-on border l'utilisateur?


    a+


    Contenu sponsorisé

    Re: Nouveau plug-in, travail en cours...

    Message  Contenu sponsorisé Aujourd'hui à 7:19


      La date/heure actuelle est Jeu 8 Déc 2016 - 7:19